Re: A simple question About OIIO and OCIO

Jeremy Selan <jeremy...@...>

Sorry for the delay.

Yah, oiiotool is definitely your way forward.

There currently isnt a way to apply .cc or .ccc grades, except using ociobakelut (and even then, this just bakes it into another lut, not into an image).

But this is an oversight; we'd love to add an oiiotool --lut and --invlut option.  (or whatever it's called).  Probably wouldn't be too difficult. Probably < 50 lines of code or so.

Alex, any interest in giving it a shot?  If so, I'm happy to sketch out the overall design for what to add where.  If you're not up for it, I'm happy to try and knock it out later this month.

-- Jeremy

On Fri, May 18, 2012 at 11:03 PM, Alex Fry <ale...@...> wrote:
Cool, so oiiotool is considered the way forward then?

Out if interest, do you know if it's possible to apply .cc or .ccc grades via any of the command line tools (ocioconvert or oiiotool)?

I'm tooling around with the possibility of making a web app to apply CDL grades and display EXR frames in a browser (as a jpg proxy). 


Alex Fry

On Saturday, 19 May 2012 at 2:41 PM, Jeremy Selan wrote:

ocioconvert is a demo app that's not really needed.  if you'd like to do color conversions, we'd recommend installing OCIO, then installing OIIO (with OCIO build-time depencency) and then trying oiio-tool --colorconvert

On Fri, May 18, 2012 at 6:14 PM, Alex Fry <ale...@...> wrote:
Ahh! I had no idea OCIO could be installed view brew..
Very neat..
Unfortunately it doesn't build it against OIIO, so its still missing ocioconvert.

But I found my original problem:
Stupidly I was using:
export OCIO_PATH=~/Developer/oiio/dist/macosx
rather than:
export OCIO_PATH=/Users/alex/Developer/oiio/dist/macosx

Thanks again

On Saturday, 19 May 2012 at 10:51 AM, Jeremy Selan wrote:

Are you on OSX?  Have you considered homebrew package manager?

I've never tried it, but if it works as advertised that would make a system install of OCIO simple.

-- Jeremy

On Fri, May 18, 2012 at 5:46 PM, Alex Fry <ale...@...> wrote:
Was there an easy answer to this?

I'm running into the same problem.


On Dec 20 2011, 4:12 pm, Jeremy Selan <jeremy...@...> wrote:
> Hmmm... That should work.  Maybe without the trailing slash on OIIO_PATH?
> (though i wouldnt expect it to make a difference).
> Perhaps you built it previously without OIIO support, and now the cmake
> files are out of date?  I'd rm the build directory and try again.
> Maybe email the exact build command you're using / output (offline)?
> -- Jeremy
> On Mon, Dec 19, 2011 at 8:44 PM, Joe <joseph...@...> wrote:
> > Hey all,
> > I'm now trying to build OCIO with the OIIO enabled.  I have built OIIO
> > and it is working  but when I set OIIO_PATH=/Users/josephslomka/
> > Documents/git/oiio/dist/macosx/
> > where I built OIIO
> > I still get the
> >  -- OIIO not found. Specify OIIO_PATH to locate it
> > from cmake.
> > Can anyone point me in the right direction?
> > Thanks.
> > -Joseph

Join to automatically receive all group messages.