Creating mipmapped textures with OpenImageIO


John Coldrick <john.c...@...>
 

Profuse apologies if this is an inappropriate place to ask about OIIO, but I couldn't find a group for it specifically...

We've been starting to use oiiotool to prep texture maps for 3D, and recently I've been getting incorrect behaviour wrt mipmapping.  We were running this on Windows and I thought perhaps it might have been an obscure bug that slipped between the cracks since most folks are probably using it on Linux, but I recently compiled oiio on centos and got the same results.

If I have an exr file, already linearized, that I wish to mipmap I run:

$ oiiotool ./mymap.exr -tile 64 64 -d half -o ./mymipmap.exr

and when I run iinfo on this I get 

mymipmap.exr : 2048 x 2048, 4 channel, half openexr


if I run:

$ maketx ./mymap.exr -tile 64 64 -d half -o ./mymipmap.exr

iinfo provides:

mymipmap.exr : 2048 x 2048, 4 channel, half openexr (+mipmap)


I've verified by testing with render packages that indeed oiiotool is not creating a mipmap and maketx is.


I've tested this with OpenImageIO 1.5.16, 1.5.22 and 1.7.1dev - same results.

Am I doing something fundamentally wrong?  Many thanks for your thoughts...

J.C.

Join ocio-dev@lists.aswf.io to automatically receive all group messages.