Re: 1.1.0 Release


Patrick Hodoul <patric...@...>
 

Using newer gcc version (i.e. 7.2.1), you are facing new warnings.

Please have a look to PR 488 where most of your problems should have been fixed:
https://github.com/imageworks/OpenColorIO/pull/488/commits/598f11d995a73d950ab85abeef1f6c2d1a15a6d9

Patrick.


On Sunday, January 7, 2018 at 9:29:37 PM UTC-5, Richard wrote:
Ok, so I changed to yaml-cpp 0.5.x (was still using 0.3.x) and got past cmake, now:

/home/build/rpmbuild/OpenColorIO/BUILD/OpenColorIO-RB-1.1/src/core/Lut1DOp.cpp:192:14: error: 'void OpenColorIO::v1::{anonymous}::Lut1D_Nearest(float*, long int, const OpenColorIO::v1::Lut1D&)' defined but not used [-Werror=unused-function]
         void Lut1D_Nearest(float* rgbaBuffer, long numPixels, const Lut1D & lut)
              ^~~~~~~~~~~~~
cc1plus: all warnings being treated as errors


Thanks,
Richard

Join ocio-dev@lists.aswf.io to automatically receive all group messages.