Re: pyOCIO Windows compilation error against Python36


Patrick Hodoul <patric...@...>
 

Hi Guys,

 

Thanks for your investigations around Python 3. 

 

OCIO does not currently support Python 3. But it would be appreciated to have a pull request fixing the Python 3 support   :-)

 

Patrick.

 


On Sunday, January 27, 2019 at 1:04:35 PM UTC-5, Richard wrote:
On Sun, Jan 27, 2019 at 12:05 AM <rena...@...> wrote:
I downloaded the latest OCIO code from GitHub (1.1.0) and I was able to compile OCIO using "Visual Studio 2015" as-well as pyOpenColorIO against Python27.

I checked online to see if I could figure out what's causing the issue but I couldn't figure it out. Anybody would know why this is happening ?
Was anyone able to compile OCIO 1.1.0 | Win64 | Visual Studio 2015 | Python36 (official 64 bit build) ?

My guess is that it hasn't been updated for Python3 yet... There are some incompatible changes.

You can try a converter and see if it takes care of the errors but beware any unintended side effects...


Thanks,
Richard 

Join ocio-dev@lists.aswf.io to automatically receive all group messages.