Re: OCIO 1.0 Build Issues On Snow Leopard


"dbr/Ben" <dbr....@...>
 

Actually, I'm still having the same error. The error occurs with the
following:

set(OCIO_VERSION_MAJOR 1)

..which sets

set(SOVERSION ${OCIO_VERSION_MAJOR} ...)

If that number is changed back to 0, it builds fine, which is slightly
bizarre, albeit related to the "-compatibility_version" in the error
message..

On Oct 28, 8:54 am, dbr/Ben <dbr....@...> wrote:
Could try with a clean build directory - I seem to recall having the same error when I just ran git pull and rerun "cmake .... && make build"

On 28/10/2011, at 6:37, Jeremy Selan <jeremy...@...> wrote:







I've built OCIO successfully on a clean install of snow leopard. Was
this a clean installation or an upgrade (for the OS install)?
-- Jeremy
On Thu, Oct 27, 2011 at 9:47 AM, Jordan Soles <jor...@...> wrote:
Hi All,
Wish I could have figured this out myself (I had no issues building pre-1.0
source on my MacBook Air Snow Leopard laptop, but I'm having issues building
the latest 1.0 source now.
I'm not doing anything crazy, and cmake actually doesn't complain at
all...but once I start the make I get the following error when the library
linking occurs:
Linking CXX shared module PyOpenColorIO.so
i686-apple-darwin10-g++-4.2.1: -compatibility_version only allowed with
-dynamiclib
make[2]: *** [src/pyglue/PyOpenColorIO.1.0.0.so] Error 1
make[1]: *** [src/pyglue/CMakeFiles/PyOpenColorIO.dir/all] Error 2
make: *** [all] Error 2
...any ideas?
Thanks,
Jordan

Join ocio-dev@lists.aswf.io to automatically receive all group messages.