Re: OCIO 1.0 Build Issues On Snow Leopard


Jeremy Selan <jeremy...@...>
 

I've just rolled this patch into master. Jordan / dbr, please let me
know if you encounter any further issues on Lion.

-- Jeremy

On Sun, Oct 30, 2011 at 6:32 AM, dbr/Ben <dbr....@...> wrote:
Aha, setting SOVERSION on Python plugins causes this error, and this
only happened with SOVERSION evaluated as true in an if() statement
(i.e not zero!)

http://seclists.org/wireshark/2010/Sep/409

Opened pull request with a fix: https://github.com/imageworks/OpenColorIO/pull/175

On Oct 30, 10:58 pm, "dbr/Ben" <dbr....@...> wrote:
Actually, I'm still having the same error. The error occurs with the
following:

set(OCIO_VERSION_MAJOR 1)

..which sets

set(SOVERSION ${OCIO_VERSION_MAJOR} ...)

If that number is changed back to 0, it builds fine, which is slightly
bizarre, albeit related to the "-compatibility_version" in the error
message..

On Oct 28, 8:54 am, dbr/Ben <dbr....@...> wrote:







Could try with a clean build directory - I seem to recall having the same error when I just ran git pull and rerun "cmake .... && make build"
On 28/10/2011, at 6:37, Jeremy Selan <jeremy...@...> wrote:
I've built OCIO successfully on a clean install of snow leopard. Was
this a clean installation or an upgrade (for the OS install)?
-- Jeremy
On Thu, Oct 27, 2011 at 9:47 AM, Jordan Soles <jor...@...> wrote:
Hi All,
Wish I could have figured this out myself (I had no issues building pre-1.0
source on my MacBook Air Snow Leopard laptop, but I'm having issues building
the latest 1.0 source now.
I'm not doing anything crazy, and cmake actually doesn't complain at
all...but once I start the make I get the following error when the library
linking occurs:
Linking CXX shared module PyOpenColorIO.so
i686-apple-darwin10-g++-4.2.1: -compatibility_version only allowed with
-dynamiclib
make[2]: *** [src/pyglue/PyOpenColorIO.1.0.0.so] Error 1
make[1]: *** [src/pyglue/CMakeFiles/PyOpenColorIO.dir/all] Error 2
make: *** [all] Error 2
...any ideas?
Thanks,
Jordan

Join ocio-dev@lists.aswf.io to automatically receive all group messages.