Support for OpenGL/GLSL > 2.0?


mark.alex...@...
 

texture3D() is also deprecated in GLSL 1.30, so it should be returning the texture() version for 1.30. An additional enum shouldn't be needed since GLSL is forward-compatible from 1.30 onwards. It's between 1.20 (GL2.x) and 1.30 (GL3.0) that there's a big break in the language.


On Thursday, May 21, 2015 at 6:41:04 AM UTC-4, Boon Hean Low wrote:
Hi everyone,

I saw that the GpuLanguage enum goes only up to GLSL 1.3, are there any plans to support anything higher? I'm using getGpuShaderText() to get the fragment shader snippets but its still using texture3D() which is deprecated in OpenGL 4.0 which I'm using now.

thanks
Boon


Boon Hean Low <boonhe...@...>
 

Hi everyone,

I saw that the GpuLanguage enum goes only up to GLSL 1.3, are there any plans to support anything higher? I'm using getGpuShaderText() to get the fragment shader snippets but its still using texture3D() which is deprecated in OpenGL 4.0 which I'm using now.

thanks
Boon