Re: GPU "EVEE" render issue Opencue

Donal McMullan
 

A quick google suggests that Evee doesn't currently support headless rendering, so on the render-node you'll need to have a display attached and presumably an X session running? There may be some workarounds where your render blades can have a virtual display - that would probably take a bit of experimentation and luck. You'd also need to have an X session running on the blade, and the user would probably have to be the same user that's trying to run the render, but I can't remember how strict the security around X sessions might be. Maya playblasts have similar requirements and I've never seen a truly non-ugly way to make it work.

But with those caveats, if the computer you're trying to render on does have a display and a desktop session running, then maybe you just need to set the DISPLAY environment variable. When you're about to run your render command manually in the CLI, if you just type "unset DISPLAY" beforehand, your process will probably fail with the same error you're seeing on OpenCue, which would confirm this. The environment variable just tells the process where to find a display to connect to. For example run this in a shell in your desktop session:
env |grep DISPLAY
DISPLAY=:0

Any GUI command you run (like say gedit) will draw its UI to DISPLAY 0 on the specified host, which is blank and therefore assumed to be localhost, if I remember correctly.

Anyway - if you capture that value from the environment of the desktop session on your render node, and ensure that DISPLAY is set to that value for the environment of your render process then I'd expect it to render. As a test you could create an executable like this and ask OpenCue to run that (with the same arguments) instead of Blender directly.

#!/bin/bash
export DISPLAY=":0"
/path/to/blender "$@"

Just some ideas. It sounds like Evee is not ideal for running on a farm but if you're motivated and prepared to make some compromises you should be able to make it work. I'd be interested to hear how that goes. Good luck :)

DJM


On Wed, 25 Sep 2019 at 15:45, <prajwal@...> wrote:
Hi All, we have been testing Opencue extensively in Blender. We have been able to successfully render on cycles. We also did check it out using addons. Everything works great! However we have run into a technical snag when dealing with GPU renderer "Evee". For some reason, Open cue throws up an error stating "Unable to open a display". We checked CLI commands which Opencue used to render and for some reason it renders :) .. same thing sent it through CueSubmit it says failed render. I have attached the Log and have tried posting this in the Blender forums. If somebody could shed some light on this that would be ace ! Thank you all in advance !

===========================================================
RenderQ JobSpec      Wed Sep 25 16:47:06 2019 

proxy                RunningFrame/08864f56-e3bc-4ec0-a111-1830cce54f6c -t:tcp -h 192.168.1.5 -p 10021
command              blender -b -noaudio /databox/00_Research_Dev/Test_Render/For_Render_v07.blend -f 1 -F JPEG
uid                  1003
gid                  20
logDestination       /shots/testing/Shot_01/logs/testing-shot_01-opencue_eevee_test--b7fa9474-d8f1-4b66-a30b-65395605cfb4/testing-shot_01-opencue_eevee_test.0001-eevee.rqlog
cwd                  /tmp/testing-shot_01-opencue_eevee_test/0001-eevee
renderHost           192.168.1.5
jobId                b7fa9474-d8f1-4b66-a30b-65395605cfb4
frameId              08864f56-e3bc-4ec0-a111-1830cce54f6c
env                  CUE3=1
env                  CUE_CHUNK=1
env                  CUE_FRAME=0001-eevee
env                  CUE_FRAME_ID=08864f56-e3bc-4ec0-a111-1830cce54f6c
env                  CUE_GPU_MEMORY=0
env                  CUE_IFRAME=1
env                  CUE_JOB=testing-shot_01-opencue_eevee_test
env                  CUE_JOB_ID=b7fa9474-d8f1-4b66-a30b-65395605cfb4
env                  CUE_LAYER=eevee
env                  CUE_LAYER_ID=4f2f5c9d-493f-4a4d-a5da-8ce976883f37
env                  CUE_LOG_PATH=/shots/testing/Shot_01/logs/testing-shot_01-opencue_eevee_test--b7fa9474-d8f1-4b66-a30b-65395605cfb4
env                  CUE_MEMORY=3355443
env                  CUE_RANGE=1-50
env                  CUE_SHOT=Shot_01
env                  CUE_SHOW=testing
env                  CUE_THREADABLE=0
env                  CUE_THREADS=1
env                  CUE_USER=opencue
env                  HOME=/net/homedirs/opencue
env                  LOGNAME=opencue
env                  MAIL=/usr/mail/opencue
env                  PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
env                  SP_NOMYCSHRC=1
env                  TERM=unknown
env                  TZ=IST
env                  USER=opencue
env                  frame=0001-eevee
env                  jobhost=192.168.1.5
env                  jobid=testing-shot_01-opencue_eevee_test
env                  logfile=testing-shot_01-opencue_eevee_test.0001-eevee.rqlog
env                  maxframetime=0
env                  mcp=1
env                  minspace=200
env                  shot=Shot_01
env                  show=testing
env                  zframe=0001-eevee
===========================================================
Blender 2.80 (sub 75) (hash f6cb5f54494e built 2019-07-29 17:17:04)
Read prefs: /home/opencue/.config/blender/2.80/config/userpref.blend
found bundled python: /plangle04/Applications/Blender/blender-2.80-linux-glibc217-x86_64/2.80/python
Read blend: /databox/00_Research_Dev/Test_Render/For_Render_v07.blend
Unable to open a display
/tmp/rqd-cmd-08864f56-e3bc-4ec0-a111-1830cce54f6c-1569410226.35: line 1: 11484 Aborted                 (core dumped) blender -b -noaudio /databox/00_Research_Dev/Test_Render/For_Render_v07.blend -f 1 -F JPEG

===========================================================
RenderQ Job Complete

exitStatus          134
exitSignal          0
startTime           Wed Sep 25 16:47:06 2019
endTime             Wed Sep 25 16:47:06 2019
maxrss              0
utime               0.41
stime               0.07
renderhost          192.168.1.5
===========================================================
 

Join opencue-user@lists.aswf.io to automatically receive all group messages.