Re: otioview core dumps in v0.12.1


Gonzalo Garramuño
 


On 30/3/20 17:05, Joshua Minor wrote:
OTIO targets the VFX Reference Platform https://vfxplatform.com/ 2016-2020, which should cover PySide 2.0.x and 5.12.x.

It looks like our setup.py asks for version 5.11 or greater: 

It is possible that something is not working in otioview in newer PySide. Can you try running otioview with PySide 5.11 or 5.12? You should be able to install that into a virtual environment with pip.

I get the following with PySide 5.11:

ImportError: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/gga/.local/lib/python2.7/site-packages/PySide2/libpyside2-python2.7.so.5.11)

As I said, the problem seems Qt related more than PySide related.  If I write a simple script, like:

---

#!/usr/bin/python

from PySide2 import *

-----

I get the same error.  It seems I would need a PySide2-5.0.9 to make it work, but it no longer exists.

With the list of PySide, I get:

$ pip install PySide2==2.0
Collecting PySide2==2.0
  Could not find a version that satisfies the requirement PySide2==2.0 (from versions: 0.0.0a1, 5.11.0, 5.11.1, 5.11.2, 5.12.0, 5.12.1, 5.12.2, 5.12.3, 5.12.4, 5.12.5, 5.12.6, 5.13.0, 5.13.1, 5.13.2, 5.14.0, 5.14.1)
No matching distribution found for PySide2==2.0

When I run it under python3.6, I get the core dump with PySide 5.11 or 5.12.

_._,_._,_
-- 
Gonzalo Garramuño

Join otio-discussion@lists.aswf.io to automatically receive all group messages.